Verbinding opzetten tussen CP343-1 en IM153-4 HF

De Modulaire PLC die vrijwel alles kan.

Moderator: GJ_

Plaats reactie
Wesley van Kuijk
Berichten: 59
Lid geworden op: 02-12-2007 23:17:37
Locatie: Raamsdonksveer

Verbinding opzetten tussen CP343-1 en IM153-4 HF

Bericht door Wesley van Kuijk » 01-09-2019 19:23:40

Hallo,

Ik ben bezig met het opzetten van een nieuwe configuratie en nu krijg ik het volgende niet voor elkaar.
Ik heb op stack 4 achter mijn CPU 315-2DP een CP343-1 gestoken met nummer 343-1EX30-0XE0.
Hiermee wil ik een Profinet netwerk maken en hieraan een ET200M module IM153-4 koppelen met nummer: 153-4BA00-0XB0.

Ik krijg een netwerk opgezet, en ik krijg geen error codes te zien in de hardware configuratie of netpro.
Nu laad ik de configuratie, maar toch blijft de leds SF (vast branden) en BF (knipperen) branden op de CP kaart, en op de ET200M kaart knippert enkel de BF led. Ik dacht in eerste instantie dat ik dit device moest assignen, maar kan dat niet vinden in de classic software.

Zou iemand mij een voorbeeld kunnen geven hoe ik dit profinet netwerk op kan zetten met de kaarten die hierboven benoemd staan?
Super bedankt alvast!

Gr Wesley
Maak het werk een stukje handiger door automatisering

JoopB
Berichten: 963
Lid geworden op: 30-11-2006 20:42:15
Locatie: Weert

Re: Verbinding opzetten tussen CP343-1 en IM153-4 HF

Bericht door JoopB » 02-09-2019 01:01:19

Heb je de slave een naam toegewezen? De naam van d Slave moet precies gelijk zijn aan de naam welke je in de HW config van Step 7 heb toegekend.

Werk je met classic of met TIA en met welke versie?

Joop

Wesley van Kuijk
Berichten: 59
Lid geworden op: 02-12-2007 23:17:37
Locatie: Raamsdonksveer

Re: Verbinding opzetten tussen CP343-1 en IM153-4 HF

Bericht door Wesley van Kuijk » 02-09-2019 16:13:39

Hallo Joop.

Bedankt alvast voor de reactie.
Ik werk met de versie 5.5 van de classic software.
Ik weet niet exact hoe je een naam toe wijst aan de slave.

Ik weet in Tia moet je assign device name doen, maar in de classic geen idee. Is het mogelijk om het in stapjes uit te leggen?

Bedankt alvast, groetjes Wesley
Maak het werk een stukje handiger door automatisering

JoopB
Berichten: 963
Lid geworden op: 30-11-2006 20:42:15
Locatie: Weert

Re: Verbinding opzetten tussen CP343-1 en IM153-4 HF

Bericht door JoopB » 02-09-2019 22:15:28

In Manager: PLC -> Edit Ethernet Node bij mac address op Browse klikken
De gewenste Profinet deelnemer selecteren en bij Assign device name de gewenste naam geven.

Verder vind je op de site van Siemens ook nog een paar programma's waar dat meestal ook mee gaat buiten S7 of TIA om.

hier Primary Setup Tool

en hier Proneta

Het kan zijn dat je je eerst moet registreren om die tools te kunnen downloaden. Asl dat zo is en er zitten export beperkingen op zal het een paar dagen duren voordat je toegang krijgt om ze te downloaden. Als de registratie geaccepteerd is kun je de meeste dingen direct downloaden. ( Soms na het beantwoorden van een paar vragen )

Ik heb hier vanmorgen ook nog eens wat zitten testen met mijn CP343-1 (dit is echter nog een EX21 dus nog wat ouder dan die van jou. Ik had alleen een ET 200S HF slave liggen, deze kreeg ik alleen ingevoegd als ik de oudste versie aanklikte, ik had in eerste instantie een 8DI en een 8DO als in en uitgang deze kon ik echter niet invoegen omdat het oude interface die niet kent, toen heb ik er een 4DI en een Counter module ingezet en ik kreeg daarmee wel communicatie, de BF led op het interface was ook uit , alleen de SF led bleef ook branden. Als ik een ingang hoog maakte werd het betreffende bit in de PLC ook hoog. Alleen voor de communicatie moet je FC11 en FC12 gebruiken uit de Simatic_Net_CP CP300 librarie.
Verder moet je een bereik aanmaken in een DB voor je IN en OUTPUT. Je kunt het beste de adressen van de Slave(s) die achter de CP zitten laten beginnen bij 0 en ze doorlopend omhoog nummeren, Want de overdracht met FC11 en FC 12 begint bij 0 een loopt dan door tot het hoogste adres.

MVG,
Joop

Plaats reactie

Terug naar “S7-300”